Outage with Email Validation Service

Incident Report for Blueshift

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 13:24 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 12:48 PDT

Investigating

Our email validation service is currently unavailable due to an ongoing issue. We are actively working to restore service as quickly as possible. We apologize for the inconvenience and appreciate your patience.
Posted Jul 13, 2026 - 11:40 PDT